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What is PHPoC Debugger?

PHPoC Debugger

PHPoC Debugger is a software used for development and management of PHPoC Products. It is
requried to install this program before using PHPoC.

Go to Download PHPoC Debugger

Features of PHPoC Debugger

Upload files from local PC to PHPoC
Save files which are in PHPoC to local PC
Edit files stored in PHPoC
Debug PHPoC scripts
Monitor PHPoC's resources
Configure PHPoC's parameters
Upgrade Firmware of PHPoC
Support Platform: MS Windows

http://ns3.phpoc.com/download.php
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User Interface

User Interface
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1. Menu bar

Menu Sub menu Description

File

New Create a new php file
Upload a poc file Upload a poc format file
Save selected file(s) Save selected files in file list to local PC
Save a poc file Save all files in file list to local PC (.poc)

Edit

Undo Undo the latest job
Redo Redo the latest job undone

Cut
Cut the selected text and copy it to the
clipboard

Copy Copy the selected text to the clipboard
Paste Paste text from the clipboard
Select all Select all texts
Find Find the specified text
Find Next Find the next text by down direction
Find Previous Find the next text by up direction
Change Replace the specified text with given text
Preferences Program preference

Function

Product / Firmware
information

Information of current firmware and product

Network information Current network information
Flash files information Information about flash files
Smart expansion board
information

Information about smart expansion boards

View PHP error log View firmware log messages in error
View firmware error log View firmware messages in error
Reboot a product Reboot a product
Firmware Debug mode Enable/disable Firmware debugging mode
PHP Debug mode Enable/disable PHP debugging mode
Font Change font
Language Change language
PHPoC Debugger
information

Information about PHPoC Debugger

help
Debugger manual(online) Go to PHPoC debugger manual page
PHPoC manual(online) Go to manual page of phpoc.com
Forum Go to PHPoC forum

Preferences

Menu Sub menu Description

View

View margin Show/hide margin
View line number Show/hide line number on margin
View current line Enable/disable current line emphasis
Auto scroll Enable/disable auto scroll
Line ratio Set line space: 100, 120, 150, 200, 300
Tab size Set tab size: 1, 2, 4, 8, 16

Action of file add
Internal editor Use the internal editor
External editor Use an external editor
Ask Show select option every time

Backup path Path of backup files

Initialization
Enter initialization
mode

Set product to initialization mode

2. COM PORT

Part for choosing a virtual USB COM port
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3. Buttons

Button Description

Connect to PHPoC product

Disconnect from PHPoC product

Configure environmental values of PHPoC product

Upload files on [File list] to PHPoC product

Stop running PHPoC codes

 
Run/pause PHPoC codes

Run line by line

Run procedure by procedure

4. File list

List of files saved PHPoC product or to be uploaded.

Icon Description
Synchronized files

Files on PHPoC product before synchronization

Files on local PC before synchronization
Synchronized files on local PC for external editors

The following menus will be popped up when right clicking on file list area.

Menu Description
Run Run the script selected immediately
New Create a new php file
Change the filename Modify file name
Add Add files from local PC
Delete Delete file on the list
Change firmware Upload the firmware selected to PHPoC

5. Editor

Showing and editing contents of selected file on the file list. The following menus will be popped up
when right clicking on editor area.

Menu Description Shortcut
Toggle Breakpoint Set / Unset break point on current line F9
Remove All Breakpoints Unset all break points on current file Shift+F9
Step Into Run line by line F11
Step Over Run procedure by procedure F10
Run to the current line Run and pause before executing the current line -
Cut Cut the selected codes and copy it to the clipboard Ctrl+X
Copy Copy the selected codes to the clipboard Ctrl+C
Paste Paste codes from the clipboard Ctrl+V
Select all Select all codes Ctrl+A
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6. Flash memory size

This shows currently available or in-use space on flash memory of PHPoC product.

7. Output / FW Log

This window is for displaying standard output and F/W log messages. The following menus will be
popped up when right clicking on the windows.

Menu Description
Delete all logs Clear screen buffer
Copy Copy the selected log to the clipboard
Auto scroll Set / Unset auto scroll

8. Watch / Resource

This window is for checking run time variable information and system resources. The following
menus will be popped up when right clicking on the watch window.

Menu Description
Add Add a variable
Modify Modify a name of the selected variable
Delete Delete the selected variables
Delete all Delete all variables
Detail Create a new window for detailed information
Refresh Refresh variables
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Installation

1. Downloading PHPoC Debugger

Download PHPoC Debugger on the link below.

Go to the Download Page

2. Running the Installation File

Unzip and run the installation file.

3. Press the "Next" button.

http://ns3.phpoc.com/download.php
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4. Select the "I accept the terms in the license agreement" option.

5. Press the "Next" button.
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6. Press the "Install" button.

7. Press the "Next" button.
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8. Press the "Finish" button.

9. Press the "Finish" button.
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Preparation

1. Install the PHPoC Debugger

Download and install PHPoC Debugger referring to the Installation chapter.

2. Connect the PHPoC to PC

Connect the device port of PHPoC to your PC via a USB cable.

3. Run the PHPoC Debugger

Select connected COM PORT and press connect ( ) button. If USB is successfully connected,

connect button will be inactivated and disconnect button ( ) will be activated

http://ns3.phpoc.com/support/manual/phpoc_debugger_manual/contents.php?id=install
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Uploading Files to PHPoC

Php files in local PC can be uploaded to PHPoC.

How to Add Files to File list

Drag & Drop

Select and drag files on Window explorer to file list box and drop them.

Add menu

If you click [Add] after right-clicking in the file list box, a window for selecting files will be created.
Selected files on the windows will be added to the file list

Upload files

Files in the file list will be uploaded to P4S-341 by clicking upload ( ) button. If the uploading
is completed, both files on the file list and in P4S-341 are synchronized and the icons are changed

to ( ).
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Upload an Integrated File(.poc)

You can upload an integrated file (.poc) with procedures below.

Click [File] > [Upload a poc file] menu.1.

Click [Open] after selecting a poc file.2.



PHPoC Debugger Manual > Major Functions > Uploading Files to PHPoC

2017-03-29 Sollae Systems page 13 of 31

Click [Upload flash files] button.3.

Choose yes or no about deleting existing flash files.4.

※ Caution: If you choose [Yes], all flash files stored in PHPoC are deleted.

Click [OK] to finish upload a poc file5.



PHPoC Debugger Manual > Major Functions > Downloading Files to PC

2017-03-29 Sollae Systems page 14 of 31

Downloading Files to PC

Downloading Files to PC

Select files in file list1.

Click [File] > [Save selected file(s)]menu on menu bar2.

Choose a path and click [OK] button.3.
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Save as a Integrated (.poc) file

When you want to save all files on the file list as a single file, use [Save a poc file] menu.

".poc" is filename extension. Input filename and click [Save] button.
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Practice

Create init.php

Notice : Operation of PHPoC

PHPoC searches init.php file after booting. If PHPoC fails to find a file named
init.php, it does not run any code. Therefore, you need to make or upload
init.php to the file system of PHPoC.
You can write main scrip to init.php but PHPoC runs the file only once. If you
wants to run their code more than once, write the main script in another file
and load the file by using "php" command of system function. A file loaded by
system function is repeatedly run even execution is ended.

Click file list with the right button of your mouse and select [New] menu.

Input "init" into the file name box.
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Select init.php file in the file list.

Input the following command lines into the editor.

Click upload button( ).

After PHPoC finishes uploading files, icon will be changed. (  → )

Excecute Scripts

PHPoC automatically runs a script when it boots up or uploads file system. You can find the result in
the Output window of PHPoC Debugger.

※ If [PHP debug mode] option of PHPoC Debugger is enabled, PHPoC does not execute a script

automatically. You can manually run the script by clicking the Run button. ( )
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Using PSP Examples

PHPoC Support Package (PSP) contains libraries and example codes. This package is provided to
help you use PHPoC conveniently. Before starting test run, download it in your local PC.

Go to the Download Page

Choosing an Example

PSP contains many examples using various sensors. Choose an example you are interested in and
upload the files to PHPoC. There are three categories.

basic task examples

These examples require uploading both "init.php" and "task0.php".

web task examples

These examples require uploading "index.php" and a set of image files if there are any.

both basic and web task examples

These examples require uploading "init.php", "task0.php" and "index.php" including a set of
image files if there are any.

http://ns3.phpoc.com/download.php
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Using Examples

Find and upload 00.hello example in the p4s/01.php_task folder.

You can find a result message right after uploading the files.
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Using an External Editor

In case that you do not want to use PHPoC Debugger's internal editor but external editor, just set
[External editor] option of [action of file add] item on preferences window.

When you upload php files with this option, the lock icons below will be shown on the synchronized
files. Files with this icon cannot be modified by internal editor of PHPoC Debugger but external
editors.
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Debugging PHP

PHPoC provides run-time debugging function. Buttons for debugging are enabled when you check
the PHP debug mode option in PHPoC Debugger. In this mode, you can set break points or check
values of variables at every code line.

Once the PHP Debug Mode is activated, debugging buttons are available. You can debug your script
with this buttons through the [Watch] window.



PHPoC Debugger Manual > Other Functions > Debugging PHP

2017-03-29 Sollae Systems page 22 of 31

Simple Tutorial

Activate the PHP Debug Mode.1.

Write the following code on init.php and upload it.2.

<?php
$var_int = 1;
$var_str = "abc";
$var_arr = array(1, 2);
?>

Clicking the right button on your mouse and select [Add] menu.3.

Enter "var_int" in the textbox as a name of variable and click [Add] button.4.

Add the following variables in the same way.5.

var_str
var_arr
var_arr[0]
var_arr[1]

Check values of variables in the [Watch] window while running the script line-by-line using6.
Step-In(F11) button.

※ Caution: In the case of a variable which is an array, key has to be specified with name of array to
watch the value
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Settings

All parameters including an IP address can be configured through PHPoC Debugger.

Setting Steps

Connect PHPoC product to PC.1.

Run PHPoC Debugger and click connect ( ) button after choosing the right COM port.2.

After then, click configuration ( ) button.3.
Configure parameters4.

Setting Parameters

Tab Category Parameter

Network

IPv4

IP address
Subnet mask
Gateway IP address
DNS server IP address
IP address type - Use static IP address
IP address type - Obtain an IP automatically (DHCP)
IP address type - Obtain DNS server address automatically

IPv6

IPv6 - Enable / Disable IPv6
IP address type - Obtain an IP automatically
IP address type - Use static IP address
EUI - MAC Address / Random
IPv6 address and Prefix
Gateway IPv6 address
Obtain DNS server address automatically
DNS server address

Wireless LAN
Basic Settings

WLAN - Enable / Disable WLAN
WLAN Topology - Ad-hoc / Infrastructure / Soft AP
Search AP / Search channel
Channel
SSID
Internal Antenna / External Antenna
Advanced Settings

Security
Shared Key
802.1X: EAP-TLS / EAP-TTLS / PEAP

Buttons

Time Set RTC time
Password Password (ID: Admin)

Certificate
Write self-signed certificate
Write signed certificate from certification authorities
Read the certificate form a device

※ Caution: PHPoC does not support restoration when you forget your password. In that case, you
can delete the password by using Factory Reset but all settings and files are also deleted.

http://ns3.phpoc.com/support/manual/phpoc_debugger_manual/contents.php?id=manage_freset
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Upgrading Firmware

New firmware can be released when adding functions or fixing bugs. If you are using old firmware,
you can upgrade it to new one. Firmware can be automatically or manually uploaded through the
PHPoC Debugger.
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Auto Upgrade

You can automatically upgrade firmware if your PC is connected to Internet.

Procedure

Connect PHPoC product to your PC.1.

Run PHPoC Debugger and click connect ( ) button after choosing the right COM port.2.

Click the [Function] > [Product/Firmware Information] menu.3.

Click the [Update] button on the Product/Firmware Information window.4.
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Click [OK] after uploading F/W is finished.5.

Upgrading F/W of Smart Expansion Boards

You can upgrade firmware of smart expansion boards if they are connected to your PHPoC board.

Connect PHPoC board with smart expansion boards to your PC.1.

Run PHPoC Debugger and click connect ( ) button after choosing the right COM port.2.

Click the [Function] > [Smart expansion board Information] menu.3.
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Click the [Update] button on the Product/Firmware Information window.4.

Click [OK] after uploading F/W is finished.5.
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Manual Upgrade

Checking the Version of F/W

Check the currnet version of F/W before upgrade it.

Checking the current version of F/W

You can check it on the [Function] > [Product/Firmware Information] menu in the PHPoC
Debugger.

Checking the latest version of F/W

You can check the latest version of F/W on download page on phpoc.com.

Procedure

Download the latest F/W file.1.
Connect PHPoC product to your PC.2.

Run PHPoC Debugger and click connect ( ) button after choosing the right COM port.3.

http://ns3.phpoc.com/download.php
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Click the [File] > [Upload a poc file] menu.4.

Select the F/W file and click the [Open] button.5.
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Click the [Upload fiwmare] button.6.

Click [OK] after uploading F/W is finished.7.
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Factory Reset

Factory Reset makes all settings of your PHPoC products to factory default including a password.
Futhermore, all files stored in flash memory are deleted as well as certificate. Because of this, you
have to backup your files before doing Factory Reset.

Factory Reset Procedure

Step Action Product State STS LED
1 Run PHPoC Debugger - -

2
Set PHPoC to initialization mode(Use
[Edit]>[Preferences] menu on PHPoC
Debugger)

Enter Initialization
mode after reboot

Blink
rapidly

3
Keep pressing the function button over 10
seconds

Preparing initialization
Blink very
rapidly

4 Check STS LED after 10 seconds Initialization ready Off

5

Release the function button right after the
STS is OFF.(※ If you don't release the button
within 2 seconds, the state go back to the
step 3)

Progressing
initialization

On

6 Rebooting automatically Initial state Off
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